Jump to content
Chris Bell

Prepar3D v4.5 (4.5.12.30293) HOTFIX 1 NOW AVAILABLE!!!

Recommended Posts

Chris Bell

 

Client Fixes and Improvements

  • Fixed performance issues seen on some systems and configurations.
  • Fixed issue where the interpolated wind direction value would be invalid in some cases.
  • Added configuration option to toggle UI hardware acceleration mode (UIHardwareAcceleration).
  • Fixed crash when re-enabling Virtual Reality (VR) while using the Oculus headset.
  • Fixed crash that could occur in some cases after a plugin removed its textures from the system.
  • Varjo eye tracking is now supported.
  • Improved performance when using the Varjo headset.
  • Fixed issue where CreateEffect callbacks would not be issued unless both xyz and pbh offsets were present.
  • CIGI ownship ID now set to 0 for versions prior to CIGI 4.0.
  • Fixed error with empty EntityAffiliation tags being written out in saved scenarios.
  • Fixed issue where sound volume could be incorrect when switching between interior and exterior views.
  • Fixed issue where PBR textures could be black in interior views when first entering a vehicle.
  • Fixed incorrect unit conversions for camera eyepoint altitude P variables.

 

Content Fixes and Improvements

  • Fixed missing PBR texture in F-16A.
  • Removed light scaling from beacon effects.

 

Scenery Fixes and Improvements

  • Increased beacon light visibility distance.

 

SDK Fixes and Improvements

  • Fixed an issue where the PBRMaterial’s effectFile property would not be updated during load.
  • Fixed an issue where 3ds Max exports would throw material mismatch errors when P3DMaterial and PBRMaterial were being used in the same scene.
  • Fixed issue with drawing and loading Annotator vegetation polygons.
  • Fixed several minor errors in documentation.

 

Thanks again for your support!

Share this post


Link to post
Share on other sites
Chris Bell

The Hotfix posted is a full blown retail release,
recommended procedure for update is full uninstall, rebuild index and flush cache,

followed by full reinstall of all elements, all your setting should remain in place unless you manually delete your user profile folders all should work fine after reinstall,

 

we will follow up LM update with new installers for all our P3D v4 titles shortly as well,

image.png

 

login to your Prepar3D account to download  latest release from LM

https://www.prepar3d.com/purchased_downloads/

 

official announcement here

https://www.prepar3d.com/news/2019/05/115307/

 

  • Thanks 1

Share this post


Link to post
Share on other sites
moey124

do i need to uninstall blackmarble and stargazer etc all products i own and download black marble and the other products own ? 

Share this post


Link to post
Share on other sites
Chris Bell

not needed atm, run refresh settings from BMNG CPanel after you reinstall 4.5 Hotfix!
when we release our new installers you will have a new option to "Update Existing Installation" in place for all your existing CDS titles,

 

NG.Cpanel.refresh.jpg

Share this post


Link to post
Share on other sites
moey124

Okay will give it a shot . I hope i dont mess up 

  • Haha 1

Share this post


Link to post
Share on other sites
bhorv67

Do you recommend to leave all addons in place (aircraft, scenery, etc...)?

Share this post


Link to post
Share on other sites
moey124

I did not do a uninstall. I went to the control panel and i ticked 3 boxes and clicked apply , is that okay and enough ? 

Share this post


Link to post
Share on other sites
Chris Bell

@bhorv67
yes, the same as with 4.5 release earlier,

leave all your addons in place uninstall than reinstall,

no need to over think it, its that simple!

 

@moey124
no clue what that means o.O 

 

guys... please keep threads on topic,
any technical question related to our products should be posted in appropriate support segment to be answered,

Share this post


Link to post
Share on other sites
moey124

@Chris Bell above u said that we must unistall the program and install , and when i asked u u said no need to do that just tick the boxes and click apply ? So i am asking u what i need to do should i do a fresh install of black marble or leave it ? 

Share this post


Link to post
Share on other sites
Chris Bell

@moey124 see my last comment? if you have something to say on this topic feel free to shoot the breeze,
if you have any further questions please ask in support area, this is announcement page for LM release!
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×